1. It can assign IP addresses to the other end
2. It can authenticate the remote device
Please go through the following post to get some idea about basic PPP configuration.
PPP Related Configuration in Cisco IOS
What will happen if we try to configure PPP in an Ethernet interface?
Well, it looks like there is no encapsulation command to set it. So following is the way to do it.
Now we are going to encapsulate PPP in Ethernet packets.
In PPPoE one has to be a Server and the other has to be a Client..
Let's take R1 as the server..
Server Configuration
Following are the steps to configure the Server..
1. Create a Virtual Template
2. Create the DHCP pool for the cient
3. Create username and password for authentication
4. Assign the Virtual Template to a BBA group
5. Enable BBA group in Ethernet interface
Let's start with the 1st step.
1. Create Virtual Template
Virtual Template is where we configure the IP address and some other PPP related settings.
Server(config)#interface virtual-template 1
Server(config-if)#ip address 192.168.12.1 255.255.255.0
Server(config-if)#mtu 1492
Server(config-if)#peer default ip address dhcp-pool CLIENT
Server(config-if)#ppp authentication chap callin
Since PPPoE adds another header of 8 Bytes, we have to reduce the MTU size to 1492.
IP address to the client will be given by the local DHCP pool "CLIENT"
Last command says that when the client attempts to connect, it will be authenticated.
2. Create the DHCP pool for the client
Server(config)#ip dhcp pool CLIENT
Server(dhcp-config)#network 192.168.12.0 /24
Server(dhcp-config)#default-router 192.168.12.1
Server(config)#ip dhcp excluded-address 192.168.12.1
Server address is excluded from the pool..
3. Create username and password for authentication
Server(config)#username CLIENT-01 password PASSWORD
Here we are not using the host name as the username.
4. Assign the Virtual Template to a BBA group
PPPoE requires a BBA group (Broad Band Access group) which is used to establish PPPoE sessions. If you want to configure session limitations per client, you should configure this. For this example I am using the global BBA.
Server(config)#bba-group pppoe global
Server(config-bba-group)#virtual-template 1
5. Enable BBA group in Ethernet interface
Server(config)#int e0/0
Server(config-if)#pppoe enable group global
Client Configuration
Now let's start configuring the Client, following are the steps..
1. Create a Dialer interface
2. Assign the Dialer interface to Ethernet interface
1. Create a Dialer interface
Client(config)#interface dialer 1
Client(config-if)#mtu 1492
Client(config-if)#encapsulation ppp
Client(config-if)#ip address negotiated
Client(config-if)#ppp chap hostname CLIENT-01
Client(config-if)#ppp chap password PASSWORD
Client(config-if)#dialer pool 1
The pool number in the last command is what configured in the Ethernet interface to refer the dialer interface..
2. Assign the Dialer interface to Ethernet interface
Now we are going to encapsulate PPP in Ethernet packets.
In PPPoE one has to be a Server and the other has to be a Client..
Let's take R1 as the server..
Server Configuration
Following are the steps to configure the Server..
1. Create a Virtual Template
2. Create the DHCP pool for the cient
3. Create username and password for authentication
4. Assign the Virtual Template to a BBA group
5. Enable BBA group in Ethernet interface
Let's start with the 1st step.
1. Create Virtual Template
Virtual Template is where we configure the IP address and some other PPP related settings.
Server(config)#interface virtual-template 1
Server(config-if)#ip address 192.168.12.1 255.255.255.0
Server(config-if)#mtu 1492
Server(config-if)#peer default ip address dhcp-pool CLIENT
Server(config-if)#ppp authentication chap callin
Since PPPoE adds another header of 8 Bytes, we have to reduce the MTU size to 1492.
IP address to the client will be given by the local DHCP pool "CLIENT"
Last command says that when the client attempts to connect, it will be authenticated.
2. Create the DHCP pool for the client
Server(config)#ip dhcp pool CLIENT
Server(dhcp-config)#network 192.168.12.0 /24
Server(dhcp-config)#default-router 192.168.12.1
Server(config)#ip dhcp excluded-address 192.168.12.1
Server address is excluded from the pool..
3. Create username and password for authentication
Server(config)#username CLIENT-01 password PASSWORD
Here we are not using the host name as the username.
4. Assign the Virtual Template to a BBA group
PPPoE requires a BBA group (Broad Band Access group) which is used to establish PPPoE sessions. If you want to configure session limitations per client, you should configure this. For this example I am using the global BBA.
Server(config)#bba-group pppoe global
Server(config-bba-group)#virtual-template 1
5. Enable BBA group in Ethernet interface
Server(config)#int e0/0
Server(config-if)#pppoe enable group global
Client Configuration
Now let's start configuring the Client, following are the steps..
1. Create a Dialer interface
2. Assign the Dialer interface to Ethernet interface
1. Create a Dialer interface
Client(config)#interface dialer 1
Client(config-if)#mtu 1492
Client(config-if)#encapsulation ppp
Client(config-if)#ip address negotiated
Client(config-if)#ppp chap hostname CLIENT-01
Client(config-if)#ppp chap password PASSWORD
Client(config-if)#dialer pool 1
The pool number in the last command is what configured in the Ethernet interface to refer the dialer interface..
2. Assign the Dialer interface to Ethernet interface
No comments:
Post a Comment